Endpoint Security, CrowdStrike, Supported Operating Systems

This is the list of operating systems currently supported by CrowdStrike.

Table of Contents

Supported Sensor Versions
Windows
macOS
Linux
Additional Information

Supported Sensor Versions

Supported Sensor Versions
Platform Sensor Versions
Windows 6.22.13616+
macOS 6.21.13403+
Linux 6.20.11711+

Windows

Server

Supported Windows Server Versions
OS Version Supported Sensor Versions End of Support Date
Server 2022 6.30.14406+ January 14, 2032
Server 2019 All supported sensor versions April 9, 2029
Server 2016 All supported sensor versions April 12, 2027
Server 2012 R2 All supported sensor versions January 10, 2024
Server 2012 All supported sensor versions January 10, 2024
Server 2008 R2 SP1 Unsupported January 14, 2021

Only 64-bit OSes are supported for Windows Server.

Desktop

Supported Windows Desktop Versions
OS Version 32-bit Support Supported Sensor Versions End of Support Date
Windows 11 False 6.31.14505+ April 7, 2025
Windows 10 v21H1 True 6.24.13806+ March 13, 2023
Windows 10 v20H2 True All supported sensor versions August 7, 2023
Windows 10 v2004 True All supported sensor versions June 12, 2022
Windows 10 v1909 True All supported sensor versions November 6, 2022
Windows 10 v1903 False Unsupported May 30, 2021
Windows 10 v1809 True 64-bit: All supported sensor versions
32-bit: 6.24.13806+
April 9, 2029
Windows 10 v1803 False Unsupported August 10, 2021
Windows 10 v1709 False Unsupported January 12, 2021
Windows 10 v1703 False Unsupported -
Windows 10 v1607 False All supported sensor versions January 21, 2027
Windows 10 v1511 False Unsupported -
Windows 10 v1507 False All supported sensor versions January 12, 2026
Windows 8.1 False All supported sensor versions April 10, 2023
Windows 8 False Unsupported -
Windows 7 SP1 True Unsupported January 14, 2021

macOS

Supported macOS Versions
OS Version Supported Sensor Versions End of Support Date
Monterey (12.x) 6.31.14404+ September 30, 2024
Big Sur (11.x) Intel Silicon: All supported sensor versions
M1 Silicon: 6.24.13701+
September 30, 2023
Catalina (10.15.x) All supported sensor versions September 30, 2022
Mojave (10.14.x) 6.25.13807 and earlier September 30, 2021
High Sierra (10.13.x) Unsupported December 28, 2020
Sierra (10.12.x) Unsupported December 30, 2019
El Capitan (10.11.x) Unsupported February 24, 2019
Yosemite (10.10.x) Unsupported November 20, 2017

Linux

Supported Linux Distributions and Versions
Distribution Version Supported Sensor Versions End of Support Date
Alma Linux 8.4 6.29.12606+ TBD
Amazon Linux 2 x86_64: All supported sensor versions*
arm64: All supported sensor versions*
TBD
AMI 2018.03 All supported sensor versions* TBD
AMI 2017.09 All supported sensor versions TBD
AMI 2017.03 Unsupported May 8, 2021
CentOS 8.4 All supported sensor versions* TBD
8.0-8.3 All supported sensor versions* TBD
7.4-7.9 All supported sensor versions TBD
7.1-7.3 Unsupported May 8, 2021
6.7-6.10 All supported sensor versions TBD
6.5-6.6 Unsupported May 8, 2021
Debian 10 All supported sensor versions* TBD
9.1-9.4 All supported sensor versions* TBD
Oracle Linux 8, UEK 6 All supported sensor versions* TBD
7, UEK 6 All supported sensor versions* TBD
7, UEK 5 All supported sensor versions* TBD
7, UEK 4 All supported sensor versions* TBD
7, UEK 3 All supported sensor versions* TBD
6, UEK 4 All supported sensor versions TBD
6, UEK 3 All supported sensor versions TBD
RHCK All supported sensor versions* TBD
Red Hat Enterprise Linux (RHEL) 8.4 6.24.12104+ TBD
8.0-8.3 All supported sensor versions* TBD
7.4-7.9 All supported sensor versions TBD
7.1-7.3 Unsupported May 8, 2021
6.7-6.10 All supported sensor versions TBD
6.5-6.6 Unsupported May 8, 2021
Rocky Linux 8.4 6.29.12606+ TBD
SUSE Linux Enterprise Server (SLES) 15.3 6.26.12303+* TBD
15.2 All supported sensor versions* TBD
15.0-15.1 All supported sensor versions TBD
12.2-12.5 All supported sensor versions* TBD
12.1 Unsupported May 8, 2021
11.4
(requires OpenSSL 1.0.1e or greater)
All supported sensor versions TBD
11.3 Unsupported -
Ubuntu 20.04 LTS All supported sensor versions* TBD
18-AWS All supported sensor versions* TBD
18.04 LTS All supported sensor versions* TBD
16-AWS All supported sensor versions* TBD
16.04.5 LTS All supported sensor versions* TBD
16.04 LTS All supported sensor versions* TBD
14.04 LTS Unsupported May 8, 2021

Unless otherwise indicated, only x86_64 OSes are supported for Linux.
All other Linux distributions and versions are unsupported.

* Some kernel versions may require a newer sensor version than indicated. See the official documentation (login required) for the complete list of supported kernels.

Additional Information

Any operating system distribution or version not listed here is likely unsupported. For the most up-to-date list, please see the official documentation for each operating system (login required):

Warning
While the CrowdStrike Falcon sensor may install on operating system versions other than these listed, the results are unpredictable. A sensor installed on an unsupported OS may cease to function, enter Reduced Functionality Mode (see below), uninstall itself, incorrectly flag system processes as malicious, or otherwise malfunction. Please take care when installing the sensor or updating your operating system.

Related articles:




Keywords:falcon, sensor, agent, version, versions, os, install, installing, installation, EPS, windows, server, desktop, workstation, mac, macos, yosemite, capitan, sierra, mojave, catalina, big, sur, monterey, linux, alma, amazon, centos, debian, oracle, redhat, rhel, rocky, suse, sles, ubuntu, lts, x86_64, x86, x64, arm, arm64, prevention, sensor, update, policy, policies, TechS-EPS-CS   Doc ID:114002
Owner:Security S.Group:University of Illinois Technology Services
Created:2021-09-28 16:37 CSTUpdated:2021-11-11 10:58 CST
Sites:University of Illinois Technology Services
Feedback:  0   0