Upside Contract - System Requirements

Software requirements for accessing Upside Contract


 Supported Operating Systems
 Supported Browsers
 Java Requirements
 Other Requirements
Microsoft Windows 10 or 11 Microsoft Internet Explorer 11 
(Compatibility View)
Firefox
Java not required
Adobe Reader
Microsoft Office for opening attachments

What it's for:
Allows for creation, approval, and management of all capital- related contract documents.
Login page:
https://upside.apps.uillinois.edu/UpsideContract6/login.aspx

Login page requires use of a Virtual Private Network (VPN)
AITS VPN
Technology Services VPN




Keywords:system requirements,client,OS,Java   Doc ID:46803
Owner:John C.Group:University of Illinois System
Created:2015-02-03 17:18 CDTUpdated:2022-03-24 11:16 CDT
Sites:University of Illinois System
Feedback:  0   0