Topics Map > Safety and Security > Malware Protection

Endpoint Security, CrowdStrike, Supported Operating Systems

This is the list of operating systems currently supported by CrowdStrike.

Table of Contents

Supported Sensor Versions
Windows
macOS
Linux
Additional Information

Supported Sensor Versions

PlatformSupported Sensor Versions
Windows6.22.13616+
macOS6.21.13403+
Linux6.20.11711+

Windows

Server

OS VersionSupported Sensor VersionsEnd of Support Date
Server 20226.30.14406+
January 14, 2032
Server 2019All supported sensor versionsApril 9, 2029
Server 2016All supported sensor versionsApril 12, 2027
Server 2012 R2All supported sensor versionsJanuary 10, 2024
Server 2012All supported sensor versionsJanuary 10, 2024
Server 2008 R2 SP1UnsupportedJanuary 14, 2021

Only 64-bit OSes are supported for Windows Server.

Desktop

OS Version32-bit SupportSupported Sensor VersionsEnd of Support Date
Windows 11 Beta
False
6.30.14406+
January 7, 2025
Windows 10 v21H1True6.24.13806+March 13, 2023
Windows 10 v20H2TrueAll supported sensor versionsAugust 7, 2023
Windows 10 v2004TrueAll supported sensor versionsMarch 14, 2022
Windows 10 v1909TrueAll supported sensor versionsAugust 10, 2022
Windows 10 v1903FalseUnsupportedMay 30, 2021
Windows 10 v1809True64-bit: All supported sensor versions
32-bit: 6.24.13806+
April 9, 2029
Windows 10 v1803FalseUnsupportedAugust 10, 2021
Windows 10 v1709FalseUnsupportedJanuary 12, 2021
Windows 10 v1703FalseUnsupported-
Windows 10 v1607FalseAll supported sensor versionsJanuary 21, 2027
Windows 10 v1511FalseUnsupported-
Windows 10 v1507FalseAll supported sensor versionsJanuary 12, 2026
Windows 8.1FalseAll supported sensor versionsApril 10, 2023
Windows 8FalseUnsupported-
Windows 7 SP1TrueUnsupportedJanuary 14, 2021

macOS

OS VersionSupported Sensor VersionsEnd of Support Date
Monterey (12.x)6.31.14404+September 30, 2024
Big Sur (11.x)Intel Silicon: All supported sensor versions
M1 Silicon: 6.24.13701+
September 30, 2023
Catalina (10.15.x)All supported sensor versionsSeptember 30, 2022
Mojave (10.14.x)6.25.13807 and earlierSeptember 30, 2021
High Sierra (10.13.x)UnsupportedDecember 28, 2020
Sierra (10.12.x)UnsupportedDecember 30, 2019
El Capitan (10.11.x)UnsupportedFebruary 24, 2019
Yosemite (10.10.x)UnsupportedNovember 20, 2017

Linux

DistributionVersionSupported Sensor VersionsEnd of Support Date
Alma Linux8.46.29.12606+TBD
Amazon Linux2x86_64: All supported sensor versions*
arm64: 6.19.11610+*
TBD
AMI 2018.03All supported sensor versions*TBD
AMI 2017.09All supported sensor versionsTBD
AMI 2017.03UnsupportedMay 8, 2021
CentOS8.46.24.12104+TBD
8.0-8.3All supported sensor versionsTBD
7.4-7.9All supported sensor versionsTBD
7.1-7.3UnsupportedMay 8, 2021
6.7-6.10All supported sensor versionsTBD
6.5-6.6UnsupportedMay 8, 2021
Debian106.20.11711+TBD
9.1-9.4All supported sensor versions*TBD
Oracle Linux8, UEK 66.16.11307+*TBD
7, UEK 66.19.11610+*TBD
7, UEK 5All supported sensor versions*TBD
7, UEK 4All supported sensor versions*TBD
7, UEK 3All supported sensor versions*TBD
6, UEK 4All supported sensor versionsTBD
6, UEK 3All supported sensor versionsTBD
RHCKAll supported sensor versionsTBD
Red Hat Enterprise Linux (RHEL)8.46.24.12104+TBD
8.0-8.3All supported sensor versionsTBD
7.4-7.9All supported sensor versionsTBD
7.1-7.3UnsupportedMay 8, 2021
6.7-6.10All supported sensor versionsTBD
6.5-6.6UnsupportedMay 8, 2021
Rocky Linux8.46.29.12606+TBD
SUSE Linux Enterprise Server (SLES)15.36.26.12303+*TBD
15.26.20.11707+*TBD
15.0-15.1All supported sensor versionsTBD
12.2-12.5All supported sensor versions*TBD
12.1UnsupportedMay 8, 2021
11.4
(requires OpenSSL 1.0.1e or greater)
All supported sensor versionsTBD
11.3Unsupported-
Ubuntu20.04 LTSAll supported sensor versions*TBD
18-AWSAll supported sensor versions*TBD
18.04 LTSAll supported sensor versions*TBD
16-AWSAll supported sensor versions*TBD
16.04.5 LTSAll supported sensor versions*TBD
16.04 LTSAll supported sensor versions*TBD
14.04 LTSUnsupportedMay 8, 2021

Unless otherwise indicated, only x86_64 OSes are supported for Linux.
All other Linux distributions and versions are unsupported.

* Some kernel versions may require a newer sensor version than indicated. See the official documentation (login required) for the complete list of supported kernels.

Additional Information

Any operating system distribution or version not listed here is likely unsupported. For the most up-to-date list, please see the official documentation for each operating system (login required):

Warning
While the CrowdStrike Falcon sensor may install on operating system versions other than these listed, the results are unpredictable. A sensor installed on an unsupported OS may cease to function, enter Reduced Functionality Mode (see below), uninstall itself, incorrectly flag system processes as malicious, or otherwise malfunction. Please take care when installing the sensor or updating your operating system.

Related articles:




Keywords:falcon, sensor, agent, version, versions, os, install, installing, installation, EPS, windows, server, desktop, workstation, mac, macos, linux, alma, amazon, centos, debian, oracle, redhat, rhel, rocky, suse, sles, ubuntu, lts, x86_64, x86, x64, arm, arm64, prevention, sensor, update, policy, policies, TechS-EPS-CS   Doc ID:114002
Owner:Security S.Group:University of Illinois Technology Services
Created:2021-09-28 17:37 CDTUpdated:2021-10-26 10:04 CDT
Sites:University of Illinois Technology Services
Feedback:  0   0