Digital Signage, Content Player Freezes or Fails at Launch

This KB offers troubleshooting steps in the case that Content Player fails to properly start on a player and stalls at the splash screen showing a communications issue.

Problem
After Content Player has been installed on a player it has been observed that when the signage client launches the application freezes or gets stuck on the splash screen with an Initializing service communications error. The player remains in this state until the window is closed or the player is rebooted. The issue appears to be caused by the local Content Player Service being in a stopped state.

Update 2.10.2020
Some posters to the FourWinds user forum have reported this same issue, primarily on older or slower computers. At the bottom of the page are instructions for changing the startup method for the service to a delayed start.

CP-Communications-Error

Steps to resolve the failure to launch:

1. Close the splash screen using the X in the right-hand corner.
3.Go to the Start menu and open Content Player Configuration
4. If the service is listed as stopped, click Start Service
    Note: You may be prompted to click OK to run the command
CP-Serviced-Stopped

5. Once the service shows as running, click OK
    Note: Starting the service will take a few seconds, click Refresh status if necessary
CP-Service-Started

6. Go to the Start menu and open Content Player, which should fully load

Alternative or Extra Steps
1. Open Windows Services Manager (Windows Administrative Tools > Services) with Run as Administrator
2. Find Content Player Service in the list
3. Change the service to Automatic (Delayed Start)
4. If the service status is blank or not running, Start the service