What version of Adobe Captivate should I install?

What version of Adobe Captivate should I install?

Faculty is advised to download Adobe Captivate 9, which is available in the Webstore at a reduced cost.

Extra resources provided by Captivate are Learning Assets and Neo Content. These are optional but do include a variety of extra features such as templates, audio files, images, etc.

64 bit is recommended for computers less than 2 years old. 32 bit for all others. Faculty should consult with IT for exact specifications needed for personal equipment.




Keywords:"Learning Management System",LMS,Blackboard   Doc ID:75647
Owner:Szymon M.Group:University of Illinois at Chicago ACCC
Created:2017-08-17 16:43 CSTUpdated:2018-08-21 13:59 CST
Sites:University of Illinois at Chicago ACCC
Feedback:  0   0