Endpoint Security, CrowdStrike, Legacy macOS Support

Information about CrowdStrike support for older versions of macOS.

Systems

CrowdStrike

Affected Customers

University of Illinois IT Pros leveraging Technology Services CrowdStrike

General Information

In May 2020, CrowdStrike announced that 5.34.11501 is the final build of the Falcon sensor for Mac that will support macOS High Sierra (10.13).

Unsupported legacy versions of macOS include:


Contact the EPS team