Topics Map > Software Applications > Mobius View

Mobius View - System Requirements

Software requirements for accessing Mobius View

 Supported Operating Systems
 Supported Browsers
 Java Requirements
 Other Requirements
Microsoft Windows 7 and 10
Apple OSX
Chrome
Firefox
Microsoft Edge
Apple OSX Safari
Microsoft Internet Explorer 11
Not Required
Adobe Reader 11
Adobe Reader DC

What it's for:
A web-enabled repository of content and reports gathered from across the various University systems

Login page:
https://mobiusview.apps.uillinois.edu/mobius/view




Keywords:system requirements,client,OS,Java, mobius,   Doc ID:46805
Owner:Xueqin L.Group:University of Illinois System
Created:2015-02-03 17:22 CDTUpdated:2020-03-30 11:47 CDT
Sites:University of Illinois System
Feedback:  2   1