System Requirements - Enterprise Applications

These requirements are based directly on the documented success and support of these products from their vendors, and therefore are the configurations supported by the AITS Service Desk.

If you have any questions about these recommendations, contact the AITS Service Desk at (217) 333-3102 or (312) 996-4806.

If you have a problem with a system that does not meet the recommended requirements, the AITS Service Desk will still make every reasonable attempt to assist you.

Windows 10 has Internet Explorer 11 installed as a secondary browser alongside the new Microsoft Edge Browser.

See Document:  Internet Explorer (Windows) - How to Find Internet Explorer 11 in Windows 10

Firefox Logo

Oracle Announcement of Mozilla Firefox Java Plugin End of Support

For information on how to run Java using JNLP ("browserless": Java Network Launch Protocol), view document:

Banner - JNLP (Simple Instructions)

Running Banner Forms using JNLP - Overview (Detailed ITPro Information)

For information on recommended Java versions, view document:

Java Recommendations for Enterprise Applications

For information on the latest browser and operating system releases, view document:

Enterprise Applications - Web Browser and OS Compatibility FAQ .

For specific recommendations on hardware, view the AITS Desktop Recommendations page.

AdAstra

 Supported Operating Systems
 Supported Browsers
 Java Requirements
 Other Requirements
Microsoft Windows Server 2008 R2 64-bit Standard Edition or higher
Microsoft Internet Explorer 11.0 (32 bit browser version is supported)
Mozilla Firefox 44+
None
 VPN Connection


 

Banner Self-Service

 Supported Operating Systems
 Supported Browsers
 Java Requirements
 Other Requirements
All
Internet Explorer 11
Firefox
Chrome (Windows only)
Safari
Java not required
 None

What it's for:
Allows students to verify and change personal information, register for classes, access financial aid information, view account billing, display grades, review academic history, request official transcripts, and more.
Allows faculty to verify and change personal information, look up class rosters, administer advising functions, submit grades, and more.
Allows staff to verify and change personal information, submit timesheets, and more.
Login page:
https://apps.uillinois.edu/selfservice
 

Banner Administrative Forms

 Supported Operating Systems
 Supported Browsers
 Java Requirements
 Other Requirements
Windows 10
Windows 8.1
Windows 8
Windows 7
Mac OS X
Internet Explorer 11*
Firefox ESR 52.0.1
Safari*
Chrome*
Java 8 (32bit)***
JNLP Connection*
 None

* JNLP (Java Network Launch Protocol) Connection does not use Java connection. 

   All browsers will work when using JNLP connection.

** Firefox no longer supports Java as of 3/2017 version 52.  Version 52.0.1 ESR supports Java Plugins.
Oracle Statement of Firefox dropping Java support

***Notice of Java 9 Release

Oracle is expected to release Java 9 for General Release on September 21st, 2017.  The current statement from Ellucian (Banner Vendor) is that Banner will not be certified for use with Java 9. They are encouraging their customers to upgrade to Banner 9 which is an entirely redeveloped web application that eliminates the use of Oracle Forms and the need for client side Java.  Oracle has removed and deprecated some functionality in Java 9 that impacts the use of the version of Oracle Forms that currently runs Banner.  

AITS is in the process of upgrading the Banner Administrative Forms to version 9 and has tentative plans to go live in the Fall of 2018.

AITS testing has confirmed that Java 9 will not run the Banner Administrative Forms. In the meantime, it’s our recommendation that departments remain on Java 8 and abstain from deploying Java 9 to their environments and make sure that Java Auto Update does not automatically update machines to Java 9.   According to Oracle, the tentative date for the end of public Java 8 updates is September of 2018.  
http://www.oracle.com/technetwork/java/eol-135779.html#Java6-end-public-updates

For information on how to make changes to Java Auto Update please refer to Oracle online documentation at:

https://www.java.com/en/download/help/java_update.xml


For information on how to connect to Banner using JNLP:
Banner Forms Support in Mozilla Firefox (Windows and Macintosh)

What it's for:
An interface for entering and accessing university administrative data for tasks related to Human Resources, Finance, and Student Administration

Login page:

https://apps.uillinois.edu/banner
 

Banner Document Management - BDM

 Supported Operating Systems
 Supported Browsers
 Java Requirements
 Other Requirements
Windows 7
Windows 8.1
Mac 10.6
Internet Explorer 11
Firefox 25.0
Chrome 31.0
Safari 5.1.7 (Windows)
Safari 6 (Mac)
Java not required
WebXtender Viewer ActiveX Plugin and components
Adobe Reader XI

What it's for:
An imaging and electronic document management system for Banner users.
Login page:
Access through Banner Administrative Forms.  Click here for BDM support.
 

Business Objects

The software requirements for accessing Business Objects are as followed:

 Supported Operating Systems
 Supported Browsers
 Java Requirements
 Other Requirements
Microsoft Windows 7, 8, 8.1
Microsoft Windows Server 2008, 2008 R2
Microsoft Windows Server 2012, 2012 R2

Internet Explorer 11
Firefox ESR
Chrome

Java 8 is currently supported

Adobe Reader 10, 11


What it's for:
An enterprise reporting tool set allowing users to view standard, pre-developed reports, and support development of custom reports and ad hoc queries for data stored in the Data Warehouse.


Login page:
https://eddie.ds.uillinois.edu

Website:
UI2 SYSTEM REQTMS website

HireTouch

Click here to see the vendor's system requirements

What it's for:
An enterprise reporting tool set allowing users to view standard, pre-developed reports, and support development of custom reports and ad hoc queries for data stored in the Data Warehouse.


Login page:
https://eas.admin.uillinois.edu/eas/servlet/EasLogin?redirect=https://appserv6.admin.uillinois.edu/appslogin/servlet/appslogin?appName=edu.uillinois.aits.HireTouchHelper


HR Front-End (HRFE)

 Supported Operating Systems
 Supported Browsers
 Java Requirements
 Other Requirements
All
Microsoft Internet Explorer 9, 10, 11
Firefox
Java not required
None

What it's for:
Perform select HR transactions using a routing and approval process before applying to Banner
Login page:
https://hr.apps.uillinois.edu/hrFrontEnd/

Legal Matters Management System LMMS (a.k.a. Legal Files)

 Supported Operating Systems
 Supported Browsers
 Java Requirements
 Other Requirements
Microsoft Windows 7
Internet Explorer 11
Java not required
Microsoft Office Add-Ins
Legal Files Drag and Drop

What it's for:
The Legal Matters Management System (LMMS) is a system used by the University Counsel Office and the University Office of Risk Management (UORM) to record, track and maintain all legal matters, including but not limited to Board Legal and medical malpractice actions , and associated expenses that involve the University of Illinois. This solution will not be used for Workers’ Compensation issues.  The vendor for the LMMS software is Legal Files Software, Inc.  The software has client/server version as well as a web/browser-based version and will be using Microsoft SQL server database.

P-Card

 Supported Operating Systems
 Supported Browsers
 Java Requirements
 Other Requirements
All
All Java not required
None

What it's for:
Entering and accessing procurement card transactions
Login page:
https://pcard.apps.uillinois.edu

Login page requires use of a Virtual Private Network (VPN)
AITS VPN
Technology Services VPN

PRZM

 Supported Operating Systems
 Supported Browsers
 Java Requirements
 Other Requirements
All
Microsoft Internet Explorer 9, 10, 11
Firefox
Chrome
Opera
Java not required
None

What it's for:
This application is used for managing construction and renovation information.

Login page:

UI Staff – PRZM Dashboard: Login
(Please use your EAS credentials.)

Vendors – PRZM Dashboard: Login
(Please use your VSA credentials.)


Illinois Contract System (iCS)

 Supported Operating Systems
 Supported Browsers
 Java Requirements
 Other Requirements
Microsoft Windows Internet Explorer 11
Firefox ESR
Safari (Viewing Only)
Java 8
None

NOTE: While Mac OS X does work with Firefox ESR, vendor does not support this configuration.  Customers may have to utilize a Windows Remote Desktop when attempting to use iCS with Mac.  From our experience, besides changing contract metadata, contracts can only be viewed using Mac OS X with Firefox ESR.

What it's for:
A contract management solution used by OBFS. Also known as Illinois Contract Service.
Login page:
https://contracts.apps.uillinois.edu

OBFS Resource Page: https://www.obfs.uillinois.edu/ics-resources/

Service Desk Manager (SDM)

 Supported Operating Systems
 Supported Browsers
 Java Requirements
 Other Requirements
All Internet Explorer
Firefox 38 ESR or higher
Safari*
Chrome
Microsoft Edge
Java not required
None

*Some functions with SDM do not work in this browser.

What it's for:

Interact with the AITS Service Desk by filing service requests and incidents to resolve IT related issues
Login page:
https://support.uillinois.edu

Tracker Electronic I-9

 Supported Operating Systems
 Supported Browsers
 Java Requirements
 Other Requirements


Any desktop OS that supports Internet Explorer or Firefox


Microsoft Internet Explorer 11*
Firefox or Internet Explorer (for Single Use New Hire Login Page)

Java not required
I9 Managers utilizing E-Verify may need to install Adobe Flash in order to complete mandatory web training

What it's for:
System for processing and storage of the Federal Form I-9, including E-Verify when appropriate
Login page:
https://appserv6.admin.uillinois.edu/appslogin/servlet/appslogin?appName=I9TrackerSSO

*For instructions on how to set up IE11 see: Document 59392 is unavailable at this time.

Travel Expense Management

 Supported Operating Systems
 Supported Browsers
 Java Requirements
 Other Requirements
All are supported.  The SAT administration tool requires Microsoft Windows. Firefox
Safari
Java 7 required for SAT admin tool only

Java 8 is currently not supported
Any PDF viewer (e.g. Adobe Reader)

NOTE: Microsoft has begun the process of scaling back their support of Internet Explorer 11 (IE 11).  While Microsoft has not overly communicated their intentions, AITS has learned this due to the fact that mandatory security patches from Microsoft are affecting applications like TEM.  Currently, TEM will not allow users who browse with IE 11 to print or view receipts.  AITS recommends using a different browser for printing and receipt viewing functions.  Internet Explorer 11 is still the only browser that is able to run the SAT administration tool. 


What it's for:
A web-based system for submitting, approving and tracking requests for travel and miscellaneous reimbursements, non-purchase order payments to vendors, and pre-trip approval.
Login page:
https://travelexpense.admin.uillinois.edu

Upside Contract

d
 Supported Operating Systems
 Supported Browsers
 Java Requirements
 Other Requirements
Microsoft Windows 7 Microsoft Internet Explorer 9 
(Compatibility View)
Firefox
Java not required
Adobe Reader
Microsoft Office for opening attachments

What it's for:
Allows for creation, approval, and management of all capital- related contract documents.
Login page:
https://upside.apps.uillinois.edu/UpsideContract6/login.aspx

Login page requires use of a Virtual Private Network (VPN)
AITS VPN
Technology Services VPN

ViewDirect - DocumentDirect

 Supported Operating Systems
 Supported Browsers
 Java Requirements
 Other Requirements
Microsoft Windows 7
Apple OSX
Internet Explorer 11
Firefox and Chrome
Apple OSX Firefox (latest version)
Java 8 (most recent release) only required for Enterprise Folders feature
Adobe Reader 11
Adobe Reader DC
ViewDirect Print Plugin (Windows Only)

What it's for:
A web-enabled repository of content and reports gathered from across the various UI-Integrate systems
Login page:
https://docdirectpweb.admin.uillinois.edu/ddrint/servlet/ddrint

Workflow

 Supported Operating Systems
 Supported Browsers
 Java Requirements
 Other Requirements
Microsoft Windows 7



Apple OSX
Internet Explorer 11
Firefox 31
Chrome 39

Safari 7
Java not required
VPN connection is required for off-campus access

What it's for:
Automates and manages the flow of information in the UI-Integrate system by streamlining Banner processes.
Login page:
https://webprod.admin.uillinois.edu/bl/servlet/BannerLogin?appName=edu.uillinois.aits.WorkFlow